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Minimum Requirements and Compatibility 
 

Upgrading from 1.0 to 2.x– Backwards Compatibility 
 

Clipstream Video 2.x was designed to be backwards compatible with previous 
versions of Clipstream Video.  This means that content encoded with the 
Clipstream Video 1.0 Plugin for Adobe Premiere will playback using the 
Clipstream Video 2.x player applet.   

 
There are a few limitations: 

 
1.0 encoded content will not be able to utilize the Seek features of 2.x 
1.0 encoded content will no be able to utilize the Security features of 2.x 
1.0 encoded content must use the new applet parameter set when using the 

2.x applet 
 

To take advantage of all of the new features of Clipstream Video 2.x it is 
recommended to re-encode video content with the Clipstream Video 2.x Plug-in 
for Adobe Premiere or the Clipstream Video Stand Alone Encoder. 

 
Minimum Video Requirements 

 
Viewing Requirements 

 
• A device capable of connecting to the internet 
• Java compatible browser, email reader or other java compatible 

software application 
• Sound generating hardware (i.e. computer sound card)  
• Sound producing hardware (i.e. speakers or headphones) 

 
On a PC 

 
o Win95 and up 
o P166 and up 
o 64 MB RAM or higher 

 
On a Mac 

 
o PowerPC Processor (200MHz or faster) 
o Internet Explorer 4.5 (or newer) with current MRJ 
o 64 MB Ram or higher 
o OS 8.1 or higher 

 
NOTE:  CPU speed drastically affects playback. 450MHz plays back 
the 500 stream nicely with a fast cable connection but with the same 
connection using a P166, 96MB RAM, the 300 sample would be the 
maximum for a smooth experience. 

 
Encoding/Creation Process Requirements 

 
• Java compatible browser 
• Text editor software for inserting applet code 
• 28.8 or faster internet connection 
• Win 95,98,NT or above 
• Sound card 
• Pentium 166Mhz CPU or better 
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• 32MB RAM 
• Hard disk storage for encoded content 

 
Serving Requirements 

 
• Any standard web server software 

o Adhere to minimum requirements as set out by your web 
server software developer 

• Any standard web server hardware 
o Adhere to minimum requirements as set out by your web 

server hardware developer 
• Bandwidth – as with any web server, the more bandwidth you have 

available, the more visitors you can serve.   
 
Java Compatibility 

 
In order to view Clipstream ™Video, your browser needs the following:  
 

• Java Virtual Machine (VM) or MRJ (this is stock in most browsers)  
• The Java option enabled  

 
Clipstream ™Video should support most 3.x and higher browsers.  If you or your 
website visitors are seeing text instead of the Clipstream ™Video player, Java 
and JavaScript must be enabled in the browser. 
 
Netscape 4.51-4.61versions prior to 6.0 for the Macintosh were shipped with a 
faulty version of Java that would not play Java audio.  This has been fixed in 
subsequent versions of Netscape 6.0 for Mac. There is no similar trouble on the 
Windows platform. 
 
NOTE: For Macintosh users MRJ required (Macintosh OS Runtime for Java).  
Currently the only browser which supports for the MRJ is MS IE4.5 or 
higher. 
 

Browser / Email Compatibility Chart 
 

Operating 
System 

Browser 
(Audio) 

Browser 
(Video) 

Email Client 
(Audio) 

Email Client 
(Video) 

Windows 
95/98/NT/2000 

IE 3+ 
NN 2+ 
IBM Homepage 
Reader 3.0 

IE 4+ 
NN 4+ 
IBM Homepage 
Reader 3.0 

OE 5.0 
Outlook 2000 
Netscape 
Messenger 
Eudora Pro 4.3 

Same as Audio 

Mac OS9 
OSX 

Netscape 4+ 
IE 4+  

Netscape 6+ 
IE 4+Same as 
Audio 

Netscape 
Messenger none 

Same as Audio 

Linux Netscape 3+ 
HotJava 1+ 

Same as Audio Netscape 
Messenger 

Same as Audio 

Solaris Netscape 3+ 
HotJava 1+ 

Same as Audio Netscape 
Messenger 

Same as Audio 

 
Enabling Browsers to View Clipstream™ 

 
Netscape Navigator 3.x 

 
1. From the menu bar, choose Options > Network Preferences.  
2. Select the Languages tab.  
3. Check boxes labeled Enable Java and Enable JavaScript.  
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Netscape Navigator 4.x and 6.x 
 

1. From the menu bar, choose Edit > Preferences.  
2. Select the Advanced category.  
3. Check boxes labeled Enable Java and Enable JavaScript. 

 
NOTE: With some old video card drivers, Java VM may fail to start if the 

video card is set to 32bit color. If the browser freezes when 
loading a web page with Clipstream or if video playback is jerky, 
try changing the color depth to 16 bit. Netscape Navigator 3.x 
and Higher 

 
1. From the menu bar, choose Options > Network 

Preferences.  
2. Select the Languages tab.  
3. Check boxes labeled Enable Java and Enable 

JavaScript.  
4. If you are using Netscape Navigator 4.x: 
5. From the menu bar, choose Edit > Preferences.  
6. Select the Advanced category.  
7. Check boxes labeled Enable Java and Enable 

JavaScript.  
 
NOTE: If your display is set to greater than 16 bit color, you will see 

TEXT instead of a VideoClipstream™ player on most ads viewed 
in Netscape 4.x. 

 
Internet Explorer 3.x 

 
1. From the menu bar, choose View > Options.  
2. Select the Security tab.  
3. Check the boxes labeled Run ActiveX scripts and Enable Java 

programs.  
 

Internet Explorer 4.x 
 

1. Internet Options.  
2. Select the Security tab.  
3. Set your security level to either Medium or Low.  

 
Internet Explorer 5.x and 6.x 
 

1. From the menu bar, choose Tools > Internet Options.  
2. Select the Security tab.  
3. Use the slider to set your security level to either Medium, Medium-low or 

Low. 
 
Internet Explorer 3.x and Higher 
 

1. From the menu bar, choose View > Options.  
2. Select the Security tab.  
3. Check the boxes labeled Run ActiveX scripts and Enable Java 

programs.  
4. If you are using Internet Explorer 4.x: 
5. From the menu bar, choose View > Internet Options.  
6. Select the Security tab.  
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7. Set your security level to either Medium or Low.  
8. If you are using Internet Explorer 5.x: 
9. From the menu bar, choose Tools > Internet Options.  
10. Select the Security tab.  
11. Use the slider to set your security level to either Medium, Medium-low or 

Low.  
 
AOL Browser 
 

1. Launch AOL Browser.  
2. After the browser loads, go to the Settings Menu on the top if the 

browser.  
3. Click on the pull-down window and click on Preferences  
4. Click on the Internet Properties (WWW) link in the Preferences dialogue  
5. Click on the Security TAB in the AOL Internet Properties dialogue  
6. Choose 'Medium' Security Level or lower.  

 
Enabling Java in Email Clients 

 
Eudora 
 

1. From the menu bar, choose Tools > Options.  
2. In the Options window, scroll down and choose Viewing Mail  
3. In the Viewing Mail box, make sure that "Allow executables in HTML 

content" is checked  
 
Outlook 
 

1. From the menu bar, choose Tools > Internet Options.  
2. Select Receive Email tab  
3. Enable HTML as the email format to be sent (also refers to the format 

that email is read in)  
 
Outlook Express 
 

1. From the main menu bar, choose Tools > Options > Security.  
2. Under the heading 'Virus Protection' and subheading 'Select the Internet 

Explorer security zone to use': Select "Internet Zone (less secure but 
more functional)"  

 
Netscape Messenger  
 

1. From the menu bar, choose Edit > Preferences  
2. Select Advanced in list  
3. Make sure that Automatically Load Images, Enable Java, and Enable 

JavaScript are checked.  
 

*** Messenger 6.0 currently does not support Java. 
 
AOL email 
 

Unfortunately, the AOL email client does not yet support Java. We 
recommend using one of the more powerful, full featured email clients 
that are available such as Eudora, Outlook, or Messenger.  
 
Note: The AOL email web interface log-on will support your Java emails 

as will any Java enabled browser. 
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WebTV 
 

Unfortunately, WebTV does not support Java, among other things.  
 
Netscape Messenger 
 

1. From the menu bar, choose Edit > Preferences  
2. Select Advanced in list  
3. Make sure that Automatically Load Images, Enable Java, and Enable 

JavaScript are checked. 
  

Java 2.0 
 
Java 2.0 is the next step in quality for audio in Clipstream Video.  It promises to 
deliver 8- and 16-bit audio data, in mono and stereo, with sample rates from 8 
kHz to 48 kHz .  The significance of Java 2.0 will be realized in superior audio 
quality approaching CD reproduction.  However, this superior quality will be 
bandwidth intensive. 
 
The proliferation of Java 2.0, and its integration and support in Clipstream Video 
technology will be driven primarily by browser support (at time of publication, only 
Netscape 6 and the latest Opera browsers supported Java 2.0) and the 
availability of high bandwidth to the majority of web users. 

 
Lotus Notes Compatibility 

 
Overview 

 
We have experienced extensive problems with the compatibility of HTML 
in the Lotus Notes email viewer.  What we have seen or have had 
reported: 

 
• HTML not appearing at all 
• HTML improperly formatted or laid out 
• HTML coding removed from the email, but applet code 

remaining 
• HTML email not being able to be forwarded 
• Applet not playing or appearing in email 
• Images not appearing in HTML email 
• Send to a friend function working, but producing errors 
• Audio applet standard buttons can be forwarded, but custom 

sets produce error 
 

Since we have been unable to get in front of a prospects system to de-
bug first hand, we have downloaded beta release 5.0.8 from Lotus to test 
with.  The prospect is using version 5.0.3.  Version 5.0.8 was able to 
handle HTML emails and our products with a standard install, although we 
did encounter problems with custom button sets in the audio applet, and 
there were distinct formatting issues with Lotus.  It should be noted that 
our testing was done with the Notes client alone and not the Notes server, 
which could also be affecting the emails.  It should also be noted that 
HTML support in Lotus is a very new concept and at slight odds with the 
structure of their document and communications management system.   
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Online help is minimal and not helpful.  Support calls have been placed to 
Lotus, and after a long run around, we found that we cannot get the 
answers we need (if they even exist) without paying a minimum of $2000 
US for a support package.  Our research has focused around the Lotus 
site, and Third party developer and discussion sites, with no official word 
from Lotus. 
 
It is possible that this problem does not have a solution that can be 
developed by Destiny.  We have not been able to test on the prospects 
system (5.0.3), thus all of our recommendations here are pure 
speculation.   

 
Possible Remedies  

 
Using Lotus Notes R5 Client Beta Release V.5.0.8 

 
• Set the notes browser setting to use MSIE 
• Change mail viewing preference to HTML and Plain Text, or 

No Preference 
• Make sure you are running Server 5.0.3 or higher with bug 

fixes and updates (less than release 5 will not support 
HTML) 

• Enable SMTP 8-bit MIME extensions on the server 
• Make sure Domino Server is not set to Notes Rich Text 

Conversion 
 

Outlook Issues 
 

Crash on Close 
 

Outlook has a bug that causes it sometimes to crash when the email 
window containing Clipstream Video is closed. To reduce this risk, the 
website author or sender of the Clipstream Video email should insert the 
following tag into their <body>.  

 
<BODY onUnload="this.focus()" > 

 
This tag keeps the focus of the email client on the email window instead 
of the Java applet.   
 
A workaround has been developed in recent builds of the 
videoclipstream.zip file but we still recommend using that tag to be sure. 

 
Double Play 
 

In some instances a user will experience what they think is the 
Clipstream Video applet playing twice at the same time, doubling up, or 
echoing.  A clip set to auto play while Outlook is using the email preview 
window could cause this situation.  In this instance, when the user 
double clicks an email entry in their email list to open it, Outlook not only 
opens up a new window with the email message that auto plays, but it 
also populates the Outlook preview window with another instance of the 
applet which auto plays.  Hence, two versions of the same streaming 
audio clip will be playing simultaneously, in separate windows, out of 
sync.  This situation can be remedied in a few ways: 
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1. Turn off auto play in the source code of the message prior to 
emailing, 

 
2. Construct a multi-part email message that will recognize the non-

scripting capability of the preview window and display an 
alternate applet that is not set to auto play.  This fix option is 
much more complex to construct than a normal HTML email. 

 
 
Have users not use the preview functionality in Outlook, or 
 

Construct a multi-part email message that will recognize the non-scripting 
capability of the preview window and display an alternate applet that is not set to 
auto play.  This fix option is much more complex to construct than a normal 
HTML email. 
 

Mac Memory Issues 
 

The MacOS and its various hardware platforms (IMac, G3, G4, etc) introduce 
several playback compatibility issues, mostly due to the way Java is integrated 
(or not integrated, to be precise) into the MacOS, which is only aggravated by 
memory issues on the lower level hardware platforms.   
 
The primary problem is that the Java Virtual Machine, as it’s known in the PC 
world, is not resident in the browser or the MacOS from version 9 and lower.  The 
MRJ requires at least 8 meg of available RAM for the System heap to expand 
into. This is *not* part of Internet Explorer’s memory partition. This is described 
by Apple TIL 22133, which can be viewed on the Web at: 
 

http://til.info.apple.com/techinfo.nsf/artnum/n22133  
 
According to Apple: 
 

“MRJ may display error messages, fail to load images or fail to play 
sounds if there is not enough memory available to run, as described in 
the Memory Usage section above. In rare cases, MRJ may crash or 
hang if it cannot get enough memory to run.” 

 
Apparently, this problem is resolved in OS X.  

 
 
 

Hotmail, Yahoo Mail and Other Free Email Service Issues 
 

Free web email viewers are widely used, but unfortunately, no substitute for a 
client based viewer that supports a wide range of presentation formats.  
Currently, free email packages such as Hotmail and Yahoo do not support Java 
applets in their viewers, and either do not process the applet, or strip it out 
completely.  There are two things a Clipstream Video author can do. 
 
First, when the applet is not processed, make sure you edit the alternate 
messaging of the applet (see section Alternate Messaging) to point to another 
web location to hear the content.  This can be accomplished with a link or other 
mechanism. 
 
Second, when the email viewer strips out the applet all together, you will need to 
provide a link outside the constraints of the applet to a place on the web where 

http://til.info.apple.com/techinfo.nsf/artnum/n22133
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the audio can be heard.  Remember, this link cannot be placed between 
<APPLET> and </APPLET> or it will not be seen.  And also remember that the 
link will always show on the page, so be sure your design and placement is 
appropriate to the page. 
 
In addition, when linking from a package like Hotmail, the link will be opened in a 
separate framed window with Hotmail’s branding.  Some of your business clients 
will not want this.  To prevent this, Place the following code into the <head> of 
the target HTML document to break out the frames: 

<script language="JavaScript"> 
<!-- 
if (parent.frames.length != 0) { 
  top.location.href=this.location; 
} 
// --> 
</script> 

 
Hosted Web Page Issues 

 
Free web pages hosted by sites such as Angelfire have a tendency to cause 
implementation problems due to restrictive server settings on file types such and 
.exe and .zip and in some instances, failure to support all non-registered file 
types. 
 
To implement on a system that will not serve or accept the .zip format is most 
common.  Hosting companies wish to prevent download sites form popping up 
and eating up their bandwidth.  This presents a problem for the 
videoclipstream.zip file, which will not be served from these systems.  Some 
minor alterations to the applet and the applet code can be made to make 
Clipstream work on these servers. 
 
Change the extension of videoclipstream.zip to videoclipstream.jar and upload it 
to the server. 
 

1. In the first line of the applet code change 
ARCHIVE=”videoclipstream.zip” to ARCHIVE=”videoclipstream.jar” 

2. Add a CODEBASE=”http://link to your site/” statement to the first line of 
the applet code. 

 
These minor changes should allow Clipstream Video to work on these sites. 
 
 

Non-Registered File Type Issues 
 
For systems that will not allow the upload of unregistered file types (the .vcs files 
for instance), these in not much that can be done with the code to accommodate 
this.  You will need to contact the Network Administrator and have these file 
types permitted.

 

http://link to your site/
http://www.clipstream.com/help/emailhelp.shtml
http://www.clipstream.com/codegen/video_codegen_simple.shtml
http://www.clipstream.com/
http://www.dsny.com/
mailto:sales@clipstream.com
mailto:help@clipstream.com

